aboutsummaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:36 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:36 +0100
commitafc4b839a31c530d73b91aa2483795f185eb7e52 (patch)
tree68655a93926a9981b4d49b66106646efbb2d7c17 /src/tests/Makefile.am
parent13ed135b9ae78c692dc359976eb8b54d0a3629b8 (diff)
Imported Upstream version 1.0.0upstream/1.0.0
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 38c4627..dc58366 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -1,3 +1,4 @@
+include $(top_srcdir)/gtester.make
noinst_PROGRAMS = \
test-modem-helpers \
@@ -10,6 +11,8 @@ if WITH_QMI
noinst_PROGRAMS += test-modem-helpers-qmi
endif
+TEST_PROGS += $(noinst_PROGRAMS)
+
################
test_modem_helpers_SOURCES = \
@@ -157,18 +160,3 @@ if WITH_QMI
test_sms_part_CPPFLAGS += $(QMI_CFLAGS)
test_sms_part_LDADD += $(QMI_LIBS)
endif
-
-################
-
-if WITH_TESTS
-
-check-local: $(noinst_PROGRAMS)
- $(abs_builddir)/test-modem-helpers
- $(abs_builddir)/test-charsets
- $(abs_builddir)/test-qcdm-serial-port
- $(abs_builddir)/test-sms-part
-if WITH_QMI
- $(abs_builddir)/test-modem-helpers-qmi
-endif
-
-endif