aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:15 +0100
committerGuido Günther <agx@sigxcpu.org>2014-02-05 08:38:15 +0100
commit87bd9deec22af69bb27226254803ac5c63b18d78 (patch)
treec34d42bf75c20b3fd740e4cd59e45aa6901a9fed /test/Makefile.am
Imported Upstream version 0.3upstream/0.3
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..3d571c3
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,23 @@
+if HAVE_PPPD_H
+
+pppd_plugindir = $(PPPD_PLUGIN_DIR)
+pppd_plugin_LTLIBRARIES = mm-test-pppd-plugin.la
+
+mm_test_pppd_plugin_la_SOURCES = \
+ mm-test-pppd-plugin.c
+
+mm_test_pppd_plugin_la_CPPFLAGS = $(MM_CFLAGS)
+mm_test_pppd_plugin_la_LDFLAGS = -module -avoid-version
+mm_test_pppd_plugin_la_LIBADD = $(MM_LIBS)
+
+endif
+
+noinst_PROGRAMS = lsudev
+lsudev_SOURCES = lsudev.c
+lsudev_CPPFLAGS = $(GUDEV_CFLAGS)
+lsudev_LDADD = $(GUDEV_LIBS)
+
+
+EXTRA_DIST = \
+ mm-test.py
+