aboutsummaryrefslogtreecommitdiff
path: root/libmm-glib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmm-glib/tests/Makefile.am')
-rw-r--r--libmm-glib/tests/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/libmm-glib/tests/Makefile.am b/libmm-glib/tests/Makefile.am
index 92c77d8..be93d4c 100644
--- a/libmm-glib/tests/Makefile.am
+++ b/libmm-glib/tests/Makefile.am
@@ -1,6 +1,7 @@
+include $(top_srcdir)/gtester.make
-noinst_PROGRAMS = \
- test-common-helpers
+noinst_PROGRAMS = test-common-helpers
+TEST_PROGS += $(noinst_PROGRAMS)
test_common_helpers_SOURCES = \
test-common-helpers.c
@@ -19,10 +20,3 @@ test_common_helpers_CPPFLAGS = \
test_common_helpers_LDADD = \
$(top_builddir)/libmm-glib/libmm-glib.la \
$(MM_LIBS)
-
-if WITH_TESTS
-
-check-local: test-common-helpers
- $(abs_builddir)/test-common-helpers
-
-endif