aboutsummaryrefslogtreecommitdiff
path: root/libqcdm/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libqcdm/src/Makefile.am')
-rw-r--r--libqcdm/src/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/libqcdm/src/Makefile.am b/libqcdm/src/Makefile.am
new file mode 100644
index 0000000..5cc0568
--- /dev/null
+++ b/libqcdm/src/Makefile.am
@@ -0,0 +1,42 @@
+noinst_LTLIBRARIES = libqcdm.la libqcdm-test.la
+
+
+libqcdm_la_CPPFLAGS = \
+ $(MM_CFLAGS)
+
+libqcdm_la_SOURCES = \
+ dm-commands.h \
+ nv-items.h \
+ com.c \
+ com.h \
+ commands.c \
+ commands.h \
+ error.c \
+ error.h \
+ result.c \
+ result.h \
+ result-private.h \
+ utils.c \
+ utils.h
+
+libqcdm_la_LIBADD = \
+ $(MM_LIBS)
+
+libqcdm_la_LDFLAGS = -Wl,--version-script=$(srcdir)/libqcdm.ver \
+ -version-info "0:0:0"
+
+
+###########################################
+# Test library without symbol versioning
+###########################################
+
+libqcdm_test_la_CPPFLAGS = \
+ $(MM_CFLAGS)
+
+libqcdm_test_la_SOURCES = \
+ utils.c \
+ utils.h
+
+libqcdm_test_la_LIBADD = \
+ $(MM_LIBS)
+