aboutsummaryrefslogtreecommitdiff
path: root/libqcdm/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libqcdm/tests/Makefile.am')
-rw-r--r--libqcdm/tests/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/libqcdm/tests/Makefile.am b/libqcdm/tests/Makefile.am
index eb38fdb..322e016 100644
--- a/libqcdm/tests/Makefile.am
+++ b/libqcdm/tests/Makefile.am
@@ -1,5 +1,8 @@
+if WITH_TESTS
+
INCLUDES = \
- -I$(top_srcdir)/libqcdm/src
+ -I$(top_srcdir)/libqcdm/src \
+ -I$(top_srcdir)/src
noinst_PROGRAMS = test-qcdm
@@ -16,14 +19,15 @@ test_qcdm_SOURCES = \
test-qcdm-result.h \
test-qcdm.c
-test_qcdm_CPPFLAGS = \
- $(MM_CFLAGS)
+test_qcdm_CPPFLAGS = $(MM_CFLAGS)
-test_qcdm_LDADD = \
- $(top_builddir)/libqcdm/src/libqcdm.la \
- $(MM_LIBS)
+test_qcdm_LDADD = $(MM_LIBS)
-if WITH_TESTS
+if QCDM_STANDALONE
+test_qcdm_LDADD += $(top_builddir)/src/libqcdm.la
+else
+test_qcdm_LDADD += $(top_builddir)/libqcdm/src/libqcdm.la
+endif
check-local: test-qcdm
$(abs_builddir)/test-qcdm