aboutsummaryrefslogtreecommitdiff
path: root/marshallers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'marshallers/Makefile.am')
-rw-r--r--marshallers/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/marshallers/Makefile.am b/marshallers/Makefile.am
new file mode 100644
index 0000000..11ce370
--- /dev/null
+++ b/marshallers/Makefile.am
@@ -0,0 +1,21 @@
+noinst_LTLIBRARIES = libmarshallers.la
+
+BUILT_SOURCES = \
+ mm-marshal.h \
+ mm-marshal.c
+
+libmarshallers_la_SOURCES = mm-marshal-main.c
+
+EXTRA_DIST = mm-marshal.list
+CLEANFILES = $(BUILT_SOURCES)
+
+libmarshallers_la_CPPFLAGS = $(MM_CFLAGS)
+libmarshallers_la_LIBADD = $(MM_LIBS)
+
+mm-marshal.h: mm-marshal.list
+ $(GLIB_GENMARSHAL) $< --prefix=mm_marshal --header > $@
+
+mm-marshal.c: mm-marshal.list
+ $(GLIB_GENMARSHAL) $< --prefix=mm_marshal --body > $@
+
+mm-marshal-main.c: mm-marshal.c mm-marshal.h