aboutsummaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am31
1 files changed, 30 insertions, 1 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 74255db..e265bc1 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -1,7 +1,10 @@
INCLUDES = \
-I$(top_srcdir)/src
-noinst_PROGRAMS = test-modem-helpers
+noinst_PROGRAMS = \
+ test-modem-helpers \
+ test-charsets \
+ test-qcdm-serial-port
test_modem_helpers_SOURCES = \
test-modem-helpers.c
@@ -13,10 +16,36 @@ test_modem_helpers_LDADD = \
$(top_builddir)/src/libmodem-helpers.la \
$(MM_LIBS)
+test_charsets_SOURCES = \
+ test-charsets.c
+
+test_charsets_CPPFLAGS = \
+ $(MM_CFLAGS)
+
+test_charsets_LDADD = \
+ $(top_builddir)/src/libmodem-helpers.la \
+ $(MM_LIBS)
+
+test_qcdm_serial_port_SOURCES = \
+ test-qcdm-serial-port.c
+
+test_qcdm_serial_port_CPPFLAGS = \
+ $(MM_CFLAGS) \
+ -I$(top_srcdir)
+
+test_qcdm_serial_port_LDADD = \
+ $(MM_LIBS) \
+ $(top_builddir)/src/libserial.la \
+ $(top_builddir)/src/libmodem-helpers.la \
+ $(top_builddir)/libqcdm/src/libqcdm.la \
+ -lutil
+
if WITH_TESTS
check-local: test-modem-helpers
$(abs_builddir)/test-modem-helpers
+ $(abs_builddir)/test-charsets
+ $(abs_builddir)/test-qcdm-serial-port
endif