aboutsummaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
new file mode 100644
index 0000000..74255db
--- /dev/null
+++ b/src/tests/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = \
+ -I$(top_srcdir)/src
+
+noinst_PROGRAMS = test-modem-helpers
+
+test_modem_helpers_SOURCES = \
+ test-modem-helpers.c
+
+test_modem_helpers_CPPFLAGS = \
+ $(MM_CFLAGS)
+
+test_modem_helpers_LDADD = \
+ $(top_builddir)/src/libmodem-helpers.la \
+ $(MM_LIBS)
+
+if WITH_TESTS
+
+check-local: test-modem-helpers
+ $(abs_builddir)/test-modem-helpers
+
+endif
+