aboutsummaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index e265bc1..cc47e66 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -4,7 +4,8 @@ INCLUDES = \
noinst_PROGRAMS = \
test-modem-helpers \
test-charsets \
- test-qcdm-serial-port
+ test-qcdm-serial-port \
+ test-sms
test_modem_helpers_SOURCES = \
test-modem-helpers.c
@@ -40,12 +41,23 @@ test_qcdm_serial_port_LDADD = \
$(top_builddir)/libqcdm/src/libqcdm.la \
-lutil
+test_sms_SOURCES = \
+ test-sms.c
+
+test_sms_CFLAGS = \
+ $(MM_CFLAGS)
+
+test_sms_LDADD = \
+ $(top_builddir)/src/libmodem-helpers.la \
+ $(MM_LIBS)
+
if WITH_TESTS
check-local: test-modem-helpers
$(abs_builddir)/test-modem-helpers
$(abs_builddir)/test-charsets
$(abs_builddir)/test-qcdm-serial-port
+ $(abs_builddir)/test-sms
endif