summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-07-18 13:15:06 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-07-18 13:15:06 +0000
commit0f28eb1c6229fb7b8bce4d83b285d6c27aa518bd (patch)
tree97beeb7834ac8680f28e6340d892c30212ad4d4f /Makefile.am
parent3cf40abfd03d483eed78505d0e9a4469e042ca95 (diff)
syncevolution.org: package ActiveSync backend separately
The syncactivesync.so backend file is no longer included in the syncevolution-bundle archives. It used to be empty anyway and just marked the ActiveSync backend as not enabled. This was necessary because the SyncEvolution reference platform, Ubuntu Lucid, does not have the necessary libs to compile activesyncd. Now a fully functional backend and activesyncd get compiled on Debian Wheezy and packaged (outside of the Makefile) as "syncevolution-activesync" and "activesyncd". See https://syncevolution.org/wiki/google-contacts-activesync
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 70eddb0b..2df623f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,8 +61,13 @@ MAINTAINERCLEANFILES += Makefile.in config.h.in config.guess config.sub configur
TEST_README_FILES = $(wildcard $(top_srcdir)/test/README.*)
+# files and file patterns which are not meant to be packaged.
DEV_FILE_PATTERN = $(1)$(2)/include $(1)$(2)/lib/*.so $(1)$(2)/lib/*.a $(1)$(2)/lib/*.la $(1)$(2)/lib/*/*.la $(1)$(2)/lib/pkgconfig
+# Exclude syncactivesync.so from bundle package because that needs to
+# be packaged separately.
+DEV_FILE_PATTERN += $(1)$(2)/lib/syncevolution/backends/syncactivesync.so
+
# binary distribution as .tar.gz
if COND_DBUS
# when building with D-Bus, we have no choice: the service has to go into /usr