summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@gmx.de>2007-10-25 21:10:48 +0000
committerPatrick Ohly <patrick.ohly@gmx.de>2007-10-25 21:10:48 +0000
commit5a5ff37001ef2b894b3d6d562542e7b1a5b69421 (patch)
tree2b0aa0136aee64288a2c8d30ac88cce69699a7fe /Makefile.am
parent0c6e2626a36124de3322fe2627b6187bc46614c8 (diff)
added package release number and dependency calculation for local Evolution libs without installed .debs
git-svn-id: https://zeitsenke.de/svn/SyncEvolution/trunk@437 15ad00c4-1369-45f4-8270-35d70d36bdcd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 23f1e488..92f869af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,9 +36,10 @@ $(IPHONE_FILENAME) : all
TYPE_deb = -D
TYPE_rpm = -R
-REQUIRES_deb = --requires="`dpkg-shlibdeps -O src/syncevolution | sed -e 's/[^=]*=//'`"
+REQUIRES_deb = --requires="`dpkg-shlibdeps -L$(srcdir)/src/shlibs.local -O src/syncevolution | sed -e 's/[^=]*=//'`"
VERSION_deb = $(VERSION)
VERSION_rpm = `echo $(VERSION) | sed -e s/-/_/g`
+RELEASE = 2
# The package name: BINSUFFIX is used to distinguish binaries
# for different Evolution releases.
@@ -62,6 +63,7 @@ deb rpm : all doc-pak
$(REQUIRES_$@) \
--fstrans=yes \
--pkgversion=$(VERSION_$@) \
+ --pkgrelease=$(RELEASE) \
--pkgname=$(PKGNAME) \
--provides=syncevolution \
--conflicts="`echo $(filter-out $(PKGNAME), $(PKGS)) | sed -e 's/ */, /g'`" \