summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@gmx.de>2008-07-29 21:06:11 +0000
committerPatrick Ohly <patrick.ohly@gmx.de>2008-07-29 21:06:11 +0000
commit5e8fa6eb94f89dd400a9314c58745bf093c74e54 (patch)
tree32e2ba28eb466f96c3686cf940bcabd8539f74c1 /Makefile.am
parent856783315912b0b1a34e5717d3358ebc0dd21be0 (diff)
major restructuring of the file layout and autotools build
This change makes it possible to add a new backend without changing any of the core files. It also gets rid of some hacks (like -export-dynamic for the binary) by putting all core SyncEvolution code into a library. The transition is not quite complete: there are still some lists of existing backends, which will be removed soon. EvolutionSmartPtr.h and EvolutionSyncSource depend on Evolution/GNOME libs, which forces all backends to use the right -I flags. git-svn-id: https://zeitsenke.de/svn/SyncEvolution/trunk@684 15ad00c4-1369-45f4-8270-35d70d36bdcd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4983fbd0..9c8e8ac4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
SUBDIRS = src test
-EXTRA_DIST = HACKING description
+EXTRA_DIST = HACKING description configure-pre.in configure-post.in autogen.sh
MAINTAINERCLEANFILES = Makefile.in config.h.in config.guess config.sub configure depcomp install-sh ltmain.sh missing mkinstalldirs
DISTCHECK_CONFIGURE_FLAGS = --with-sync4j=@FUNAMBOL@
@@ -79,3 +79,18 @@ doc-pak : README NEWS COPYING
description-pak : description
cp $< $@
+
+# TODO: make configurable
+$(srcdir)/configure.in: configure-pre.in configure-post.in src/backends/addressbook/configure-sub.in src/backends/evolution/configure-sub.in src/backends/sqlite/configure-sub.in
+ rm -f $@
+ cat $(srcdir)/configure-pre.in >>$@
+ for sub in $(srcdir)/src/backends/*/configure-sub.in; do \
+ echo "# vvvvvvvvvvvvvv $$sub vvvvvvvvvvvvvv" >>$@; \
+ cat $$sub >>$@; \
+ echo "AC_CONFIG_FILES(`echo $$sub | sed -e 's;^$(srcdir)/;;' -e s/configure-sub.in/Makefile/`)" >>$@; \
+ echo "# ^^^^^^^^^^^^^^ $$sub ^^^^^^^^^^^^^^" >>$@; \
+ echo >>$@; \
+ done
+ echo BACKEND_REGISTRIES = `echo $(srcdir)/src/backends/*/*Register.cpp | sed -e 's;$(srcdir)/;;'` >>$@
+ echo "AC_SUBST(BACKEND_REGISTRIES)" >>$@
+ cat $(srcdir)/configure-post.in >>$@