summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKrzesimir Nowak <krnowak@openismus.com>2012-01-23 16:09:28 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2012-01-25 10:02:19 +0000
commit5ea4afddaa1d184870ebab95de5e0bcc3625e720 (patch)
treeb8e738f0f415d500425e22483914fa5299f9cb36 /Makefile.am
parentd4b3ded8d8e68d7dedf45dc9d18008d82c1570c9 (diff)
Add another hack for installation.
libsyncevolution depends on libgdbussyncevo. On installation the former needs to be relinked, but the latter is still not installed and that causes linking to fail with following message: /usr/bin/ld: cannot find -lgdbussyncevo That is so, because the order of installing binaries is not dependency-based but more like target directory based: install-exec-am: install-binPROGRAMS install-binSCRIPTS \ install-libLTLIBRARIES install-libexecPROGRAMS \ install-libexecSCRIPTS install-nodist_binSCRIPTS \ install-pkglibLTLIBRARIES libsyncevolution is installed during install-libLTLIBRARIES, while its dependency is installed during later install-pkglibLTLIBRARIES.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 10f5b121..8896c70b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -303,6 +303,7 @@ dist-hook: $(all_dist_hooks)
# during concurrent distcheck (a backed was relinked against not yet installed
# libsyncevolution.la).
install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-pkglibLTLIBRARIES
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am
@$(MAKE) $(AM_MAKEFLAGS) install-data-am