summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2011-08-17 09:57:50 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2011-08-17 10:04:21 +0000
commit6099214016ee08d2c15b6a8d93d36e595dcaf597 (patch)
tree4aee1ea5cd47c8928fcf61fd0d2bd9f3e557f486 /Makefile.am
parent1af59c855f97b3625e8f512f896e030e477fa80c (diff)
syncevolution.org binaries: work with both libneon and libneon-gnutls
When --enable-neon-compatibility is used, libneon.so.27 and libneon-gnutls.so.27 are opened dynamically instead of linking against them. The Debian package specifies that it depends on one of these two libs in this case. Don't use --enable-neon-compatibility when not enabling WebDAV to avoid this dependency. This change is necessary for Debian Testing, which no longer has libneon.so.27 at all. Note that the very latest Debian Testing also has another problem because libnotify1 was dropped in favor of libnotify4.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d1242e52..dbfd322d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -92,7 +92,14 @@ TYPE_rpm = -R
# Dependency calculation is intentionally incomplete:
# - don't force dependency on specific EDS libs via backends, their versions change too much (handled via --enable-evolution-compatibility and dynamic loading of the backends)
# - ignore client-test dependencies (because users typically don't run it)
-REQUIRES_deb = --requires="'$(shell set -x; cd dist; LD_LIBRARY_PATH=$(distdir)/usr/lib:$(distdir)/usr/lib/syncevolution dpkg-shlibdeps -L$(srcdir)/src/shlibs.local --ignore-missing-info -O $$(for i in $$(find $(distdir) -type f -perm /u+x | grep -v -e client-test -e lib/syncevolution/sync); do if file $$i | grep ELF >/dev/null; then echo $$i; fi; done) | sed -e 's/[^=]*=//')'"
+REQUIRES_deb = --requires="'$(shell set -x; cd dist; LD_LIBRARY_PATH=$(distdir)/usr/lib:$(distdir)/usr/lib/syncevolution dpkg-shlibdeps -L$(srcdir)/src/shlibs.local --ignore-missing-info -O $$(for i in $$(find $(distdir) -type f -perm /u+x | grep -v -e client-test -e lib/syncevolution/sync); do if file $$i | grep ELF >/dev/null; then echo $$i; fi; done) | sed -e 's/[^=]*=//')$(REQUIRES_deb_neon)'"
+if NEON_COMPATIBILITY
+# --enable-neon-compatibility in src/backends/webdav:
+# replace dependencies from linking with hard-coded dlopen() dependencies
+REQUIRES_deb_neon = , libneon27 (>= 0.29.0) | libneon27-gnutls (>= 0.29.0)
+else
+REQUIRES_deb_neon =
+endif
VERSION_deb = 1:$(STABLE_VERSION)$(VERSION)
VERSION_rpm = `echo $(VERSION) | sed -e s/-/_/g`
RELEASE = 2