summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@gmx.de>2007-10-21 21:23:15 +0000
committerPatrick Ohly <patrick.ohly@gmx.de>2007-10-21 21:23:15 +0000
commit7e7201c9fc109d0c46a6e4ce3c8e72ce77156881 (patch)
tree582c64d0f9a34a6384ec16bfdf00405fe8374ae8 /Makefile.am
parent2ecde008bab7f9db96e942bee60fa49b6b6b587d (diff)
# updated packaging: added provides/conflicts
git-svn-id: https://zeitsenke.de/svn/SyncEvolution/trunk@429 15ad00c4-1369-45f4-8270-35d70d36bdcd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b46fd495..23f1e488 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,14 @@ REQUIRES_deb = --requires="`dpkg-shlibdeps -O src/syncevolution | sed -e 's/[^=]
VERSION_deb = $(VERSION)
VERSION_rpm = `echo $(VERSION) | sed -e s/-/_/g`
+# The package name: BINSUFFIX is used to distinguish binaries
+# for different Evolution releases.
+PKGNAME=syncevolution$(patsubst %,-%,$(BINSUFFIX))
+
+# This is a list of packages (potentially) provided on estamos.de.
+# The current package conflicts with any of them, but not itself.
+PKGS = $(addprefix syncevolution-evolution-, 2.0 2.2 2.4 2.6 2.8 2.10 2.12 2.14 2.16)
+
# When calling checkinstall we cannot install into /tmp
# because any file created there will be excluded: that makes
# sense, because "make install" might create temporary files
@@ -54,10 +62,13 @@ deb rpm : all doc-pak
$(REQUIRES_$@) \
--fstrans=yes \
--pkgversion=$(VERSION_$@) \
- --pkgname=syncevolution$(patsubst %,-%,$(BINSUFFIX)) \
+ --pkgname=$(PKGNAME) \
+ --provides=syncevolution \
+ --conflicts="`echo $(filter-out $(PKGNAME), $(PKGS)) | sed -e 's/ */, /g'`" \
--maintainer='Patrick Ohly <patrick.ohly@gmx.de>' \
--pkgsource='http://sourceforge.net/project/showfiles.php?group_id=146288' \
--pkgaltsource='http://www.estamos.de/projects/SyncML/' \
+ --pkggroup='gnome' \
--docdir=$$docdir $(MAKE) install
doc-pak : README NEWS COPYING