summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-06-15 10:20:46 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-06-15 10:20:46 +0000
commit98bd5e2b5908a135662c8dda2ee55689d53e5cac (patch)
tree821c2c5a98152c9e843b477cc8c1392b48b077d1 /Makefile.am
parent603d036b687e350d2545bd90252c23297fea0a22 (diff)
syncevolution.org: fix for packaging
The previous commit broke parallel "make deb" (because mv *.deb matched different package builds and then mv only succeeded for one) and "make rpm" (because the mv was looking in the wrong place).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 97347365..04ed25d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,7 +181,7 @@ deb rpm : checkinstall/dist/$(distdir) checkinstall/dist/debian/control
--pkggroup='$*' \
--pkggroup='comm' \
cp -r `pwd`/dist/$(distdir)/* / && \
- if [ $@ = "rpm" ]; then cp /usr/src/rpm/RPMS/*/${PKGNAME}-${VERSION}-2.*.rpm ..; else mv *.deb ..; fi
+ if [ $@ = "rpm" ]; then cp /usr/src/rpm/RPMS/*/${PKGNAME}-${VERSION}-2.*.rpm ..; else mv ${PKGNAME}_${VERSION}*.deb ..; fi
# Pseudo platform .deb packages:
# only depend on PKGNAME = syncevolution-$(BINSUFFIX) (usually syncevolution-bundle).
@@ -221,7 +221,7 @@ syncevolution-%-deb: checkinstall/dist/$(distdir) checkinstall/dist/debian/contr
--pkgsource='http://syncevolution.org' \
--pkggroup='$*' \
sh -c 'mkdir -p touch /usr/share/doc/syncevolution-$* && echo "SyncEvolution platform pseudo-package for $*" >/usr/share/doc/syncevolution-$*/README' && \
- mv *.deb ..
+ mv syncevolution-$**.deb ..
all_phonies += checkinstall/dist/$(distdir) clean_dist
checkinstall/dist/$(distdir): all