summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-01-16 11:47:10 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2012-01-16 11:47:10 +0100
commitf1bffbc1a4b178cb701e51ed1c6caadc71128e95 (patch)
tree099e151072aef896a0b03394445c26791c085cad /Makefile.am
parentb240b6d4c4c21479c53da3d9d2cc6e836543845d (diff)
parent09ce2bb579dc6d25e1efe9b6bc435f97c2ac322c (diff)
Merge commit 'syncevolution-1-2-2'
Conflicts: Makefile.am configure-post.in configure.ac src/Makefile-gen.am src/dbus/qt/Makefile.am src/syncevo-dbus-server.cpp test/test-dbus.py Conflicts caused by renaming of files on master. Manually applied the relevant changes to the renamed files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index bfb7304d..b7fd1f8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -238,19 +238,30 @@ toplevel_so_check:
done
endif
+# Be strict about running 'syncevolution' only when not doing
+# cross-compilation: in that case, if running 'syncevolution' fails,
+# abort the build process. Otherwise proceed with the fallback below,
+# which is to keep the "see --sync/source-property ?" placeholders in
+# the README.
+if COND_CROSS_COMPILING
+RUN_SYNCEVOLUTION_CHECK=if ($$?) { return ""; } else { return $$buffer; }
+else
+RUN_SYNCEVOLUTION_CHECK=die if $$?; return $$buffer;
+endif
+
# patch README.rst properties on-the-fly
README.patched.rst: README.rst src/syncevolution
$(AM_V_GEN)perl -e '$$syncfound=0; $$sourcefound=0; $$res=0;' \
- -e 'sub run { $$cmd = shift; $$buffer = `$$cmd`; die if $$?; return $$buffer; }' \
+ -e 'sub run { $$cmd = shift; $$buffer = `env LD_LIBRARY_PATH=src/syncevo/.libs:src/gdbus/.libs:src/gdbusxx/.libs:src/build-synthesis/src/.libs:$$ENV{LD_LIBRARY_PATH} $$cmd`; $(RUN_SYNCEVOLUTION_CHECK) }' \
-e 'while (<>) {' \
-e 's/^:Version: .*/:Version: $(VERSION)/;' \
-e 's/:Date: .*/":Date: " . `date +%Y-%m-%d`/e;' \
- -e 'if (s;<<insert sync-property>>\n;run("src/syncevolution --daemon=no --sync-property ?");e) { $$syncfound=1; }' \
- -e 'if (s;<<insert source-property>>\n;run("src/syncevolution --daemon=no --source-property ?");e) { $$sourcefound=1; }' \
+ -e 'if (s;(<< see "syncevolution --sync-property ." >>\n);run("src/syncevolution --daemon=no --sync-property ?") || $$1;e) { $$syncfound=1; }' \
+ -e 'if (s;(<< see "syncevolution --source-property ." >>\n);run("src/syncevolution --daemon=no --source-property ?") || $$1;e) { $$sourcefound=1; }' \
-e 'print;' \
-e '}' \
- -e 'die "<<insert sync-property>> not in README.rst?!" unless $$syncfound;' \
- -e 'die "<<insert source-property>> not in README.rst?!" unless $$sourcefound;' \
+ -e 'die "<<sync-property>> tag not in README.rst?!" unless $$syncfound;' \
+ -e 'die "<<source-property>> tag not in README.rst?!" unless $$sourcefound;' \
-e 'exit $$res;' \
$< >$@
CLEANFILES += README.patched.rst