summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-02-28 20:35:25 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-02-28 20:41:38 +0000
commitf944a6087acd7f3195b90432202c053169681239 (patch)
treebc97088ee09bfb8e152bcf4fac4de5faa2409724 /Makefile.am
parenta412e11cb07acfa46059d1b6b993fd2f6cd999f7 (diff)
autotools: special KDE dependencies for syncevolution.org .deb
Compiling on Ubuntu Lucid and finding package dependencies with dpkg-shlibdeps led to a .deb which wasn't installable on Debian Testing because the kdelibs5 and kdepimlibs5 are no longer provided. They were replaced with individual library packages. Handle that by overriding the output of dpkg-shlibdeps when it contains kdelibs5 or kdepimlibs5 and allow the more recent packages as alternative.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 10f5b121..3afb0774 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,7 +119,12 @@ TYPE_rpm = -R
# Dependency calculation is intentionally incomplete:
# - don't force dependency on specific EDS libs via backends, their versions change too much (handled via --enable-evolution-compatibility and dynamic loading of the backends)
# - ignore client-test dependencies (because users typically don't run it)
-REQUIRES_deb = --requires="'$(shell set -x; cd dist; LD_LIBRARY_PATH=$(distdir)/usr/lib:$(distdir)/usr/lib/syncevolution dpkg-shlibdeps -L$(srcdir)/src/shlibs.local --ignore-missing-info -O $$(for i in $$(find $(distdir) -type f -perm /u+x | grep -v -e client-test -e lib/syncevolution/sync); do if file $$i | grep ELF >/dev/null; then echo $$i; fi; done) | sed -e 's/[^=]*=//')$(REQUIRES_deb_neon)'"
+# - be more flexible about kdelibs5 than dpkg-shlibdeps: it is found as package
+# for libkdeui.so.5 and libkdecore.so.5 on Ubuntu Lucid, but after Debian
+# Squeeze the package was replaced by individual library packages. On such
+# distros, libkdeui5 is what we need.
+# - same for kdepimlibs5 -> libakonadi-kde4
+REQUIRES_deb = --requires="'$(shell set -x; cd dist; LD_LIBRARY_PATH=$(distdir)/usr/lib:$(distdir)/usr/lib/syncevolution dpkg-shlibdeps -L$(srcdir)/src/shlibs.local --ignore-missing-info -O $$(for i in $$(find $(distdir) -type f -perm /u+x | grep -v -e client-test -e lib/syncevolution/sync); do if file $$i | grep ELF >/dev/null; then echo $$i; fi; done) | sed -e 's/kdelibs5 ([^,]*),/kdelibs5 | libkdeui5,/g' -e 's/kdepimlibs5 ([^,]*),/kdepimlibs5 | libakonadi-kde4,/g' -e 's/[^=]*=//')$(REQUIRES_deb_neon)'"
if NEON_COMPATIBILITY
# --enable-neon-compatibility in src/backends/webdav:
# replace dependencies from linking with hard-coded dlopen() dependencies