summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kühl <chrisk@openismus.com>2011-09-21 14:34:07 -0700
committerPatrick Ohly <patrick.ohly@intel.com>2011-11-29 16:38:38 +0000
commit103dfe4f7385badb10a332c121f602341fea3eec (patch)
tree2f499622a53f6e817ec4d4225689c03ce2a9cabe /configure.ac
parent29fee7a2bcccc2241c7fb2ed34c0841f6e857600 (diff)
build: Enable configure switch to build with GIO GDBus
syncEvolution has used an in-tree copy of Bluez's gdbus dbus implentation. With this patch there is now a configure switch which enables the use of the GLib's GDBus dbus implmentation if the --with-gio-gdbus configure flag is use or, if no flag is used, an adequate glib version (2.26) is found. This commit does *not* actually implement the use of GIO's GDBus. The implmentation is coming soon. Thus only --without-gio-gdbus will currently result in a working build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ceec637..17324196 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,6 +440,17 @@ AC_ARG_ENABLE(dbus-service,
fi])
AM_CONDITIONAL([COND_DBUS], [test "$enable_dbus_service" = "yes"])
+AC_ARG_WITH(gio-gdbus,
+ AS_HELP_STRING([--with-gio-gdbus],
+ [enables use of GIO's GDBus instead of the in-tree, Bluez gdbus.]),
+ with_gio_gdbus="$withval",
+ PKG_CHECK_EXISTS([gio-2.0 >= 2.26],
+ [with_gio_gdbus="yes"],
+ [with_gio_gdbus="no"]))
+AM_CONDITIONAL([COND_GIO_GDBUS], [test "x$with_gio_gdbus" = "xyes"])
+AS_IF([test "x$with_gio_gdbus" = "xyes"], [need_glib=yes
+ PKG_CHECK_MODULES([GIO_GDBUS], [gio-2.0 >= 2.26])] )
+
PKG_CHECK_MODULES(KEYRING, [gnome-keyring-1], HAVE_KEYRING=yes, HAVE_KEYRING=no)
AC_ARG_ENABLE(gnome-keyring,
AS_HELP_STRING([--enable-gnome-keyring],
@@ -1070,6 +1081,7 @@ for backend in $BACKENDS; do
eval echo $backend: \${enable_${backend}}
done
echo "DBus service: $enable_dbus_service"
+echo "GIO GDBus: $with_gio_gdbus"
echo "GNOME keyring: $enable_gnome_keyring"
echo "UI (DBus client): $enable_gui"
echo "Bluetooth transport: $have_bluetooth"