summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-05-29 08:38:57 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-05-29 08:38:57 +0000
commit2b058e6a2993be956eaa1efa126bb9db102d0162 (patch)
treeb79f1ebb66825bfb46099d7d79157823ad8ed0a9 /configure.ac
parentd54789ad376ab3ad8783e930e68c258b2f03abe9 (diff)
autotools: allow usage of deprecated functions
GTK UI and Bluetooth plugin use some methods which were marked deprecated in 3.4.2 (Debian Testing). Allow that until someone finds the time to remove the offending function usage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 873638a5..31ff47ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,8 +66,8 @@ AC_PROG_MAKE_SET
# currently uses the "#pragma }" trick. Should remove that.
# Fix code to work without deprecated methods: G GDK GDK_PIXBUF CAIRO PANGO GTK
DK_ARG_ENABLE_WARNINGS([SYNCEVO_WFLAGS],
- [-Wall -Wno-unknown-pragmas],
- [-Wall -Wno-unknown-pragmas],
+ [-Wall -Wno-unknown-pragmas -Wno-deprecated-declarations],
+ [-Wall -Wno-unknown-pragmas -Wno-deprecated-declarations],
[])
dnl default device type (see AC_DEFINE below)