summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-08-14 15:50:06 +0200
committerPatrick Ohly <patrick.ohly@intel.com>2012-10-25 16:43:46 +0200
commit4107353d14ff3f386ea2170e5099a08a9335fa59 (patch)
treeb8d8e97d64617bad6c337e9e8dc4f62a3428beca /configure.ac
parent849c5408e582189e92d920176109e97111ced043 (diff)
PIM Manager: autotools + libfolks + API
Initial step towards using SyncEvolution, PBAP and libfolks in the context of IVI (in-vehicle-infotainment): D-Bus API definition for the org._01.pim.contact API, --enable-dbus-service-pim, find libs, compile into syncevo-dbus-server and client-test. The only functional code at this time is the unit testing of libfolks, GValueCXX and libgee.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bf3b2a0..298b0f12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -515,8 +515,23 @@ if test $enable_dbus_service = "yes"; then
MLITE_LIBS=
fi
AC_DEFINE(DBUS_SERVICE, 1, [define if dbus service is enabled])
+
+ AC_ARG_ENABLE(dbus-service-pim,
+ AS_HELP_STRING([--enable-dbus-service-pim],
+ [enable implementation of org._01.pim D-Bus APIs (depends on libfolks)]),
+ [ enable_dbus_pim="$enableval" ],
+ [ enable_dbus_pim="no" ])
+ case "$enable_dbus_pim" in
+ no) ;;
+ yes)
+ PKG_CHECK_MODULES(FOLKS, [folks])
+ AC_DEFINE(ENABLE_DBUS_PIM, 1, [org._01.pim D-Bus API enabled])
+ ;;
+ *) AC_MSG_ERROR([invalid value for --enable-dbus-service-pim: '$enable_dbus_pim']);;
+ esac
fi
AM_CONDITIONAL([NOTIFY_COMPATIBILITY], [test "$enable_notify_compat" = "yes"])
+AM_CONDITIONAL([COND_DBUS_PIM], [test "$enable_dbus_pim" = "yes"])
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
@@ -1023,6 +1038,7 @@ for backend in $BACKENDS; do
eval echo $backend: \${enable_${backend}}
done
echo "DBus service: $enable_dbus_service"
+echo "org._01.pim support in DBus service: $enable_dbus_pim"
echo "Notifications: $enable_notify"
echo "GIO GDBus: $with_gio_gdbus"
echo "GNOME keyring: $enable_gnome_keyring"