summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-10-05 06:36:42 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-10-05 06:39:26 +0000
commit42c2e0d203ad1b525eb5db265d91b46f31e719e8 (patch)
treec93f258cae4e0068d536230d519c59d4cc04ce65 /configure.ac
parent108f4c8da1cc0412bc263ac9ff4592ffd32da21d (diff)
GTK-3 UI: fixed compile problem
The GTK-3 UI depends on a class from gio-unix-2.0 and failed to compile on Fedora Core 16 because the configure checks for that lib (and thus the compiler flags) were missing: src/gtk3-ui/sync-ui.c:30:33: fatal error: gio/gdesktopappinfo.h: No such file or directory Reported by Peter Robinson.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 14fa75dc..6c55e372 100644
--- a/configure.ac
+++ b/configure.ac
@@ -559,7 +559,7 @@ if test $enable_gui != "no"; then
AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool)
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
- gui_modules="$gtk_version glib-2.0 dbus-glib-1 >= 0.60 gio-2.0"
+ gui_modules="$gtk_version glib-2.0 dbus-glib-1 >= 0.60 gio-2.0 gio-unix-2.0"
if test $enable_gui = "moblin"; then
AC_DEFINE(USE_MOBLIN_UX, 1, [Use Moblin UI widgets])
fi