summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-01-27 15:05:06 +0000
committerPatrick Ohly <patrick.ohly@intel.com>2012-02-01 15:28:00 +0000
commit4928d51eca6be40b1bb063d78c21fd2b946c4cdc (patch)
tree2c412eba16b7cce5bcf04952401d4f77292fb2ef /configure.ac
parent72eed2087fffdf2bbe326f71ade27e77479ddf5f (diff)
Akonadi: fixed compile and runtime issues
Due to bitrot the Akonadi backend and KWallet support code no longer worked. Moved the common code for KApplication initialization into libsyncevolution's SyncContext::initMain() and fixed autotools rules. The old code always tried to contact an X server (default constructor of KApplication). That doesn't seem to be necessary and is avoided now. Even better might be to skip KApplication entirely and instead use QCoreApplication and KComponentData, as suggested by http://api.kde.org/4.x-api/kdelibs-apidocs/kdeui/html/classKApplication.html KAboutData was incorrectly passed the address of a string pointer, not the pointer itself. Testing the Akonadi backend in client-test failed because client-test always overwrites the "backend" value with "Test_kde_[contact/event/..]._[1/2]". Now this special case is detected. The backend then uses the first resp. second resource that it finds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52ab6964..abd5ea91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,7 +498,7 @@ then
then
KDEKWALLETFOUND=yes
if ! test "$KDE_KWALLET_CFLAGS"; then
- KDE_KWALLET_CFLAGS="-I`$KDE4_CONFIG --path include` -I`$KDE4_CONFIG --path include`/KDE -I`$QMAKE -query QT_INSTALL_HEADERS`"
+ KDE_KWALLET_CFLAGS="-I`$KDE4_CONFIG --path include` -I`$KDE4_CONFIG --path include`/KDE -I`$QMAKE -query QT_INSTALL_HEADERS` `pkg-config --cflags QtDBus`"
fi
if ! test "$KDE_KWALLET_LIBS"; then
KDE_KWALLET_LIBS="-lkdeui -lkdecore `pkg-config --libs QtDBus`"