summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2013-02-19 10:09:10 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2013-02-26 12:03:45 +0100
commit7214834e0b202df04d1f113321fd51fd2e48f45e (patch)
tree775aa7c8ccd55964bf9f6a8ddb9d3ad1fbcab0ba /configure.ac
parentd3257fe7fd4e277d7303fed2bafdaa5e8d423df6 (diff)
autotools: avoid -lrt in make dependencies
The backends had SYNCEVOLUTION_LIBS in their _DEPENDENCIES entries, which is wrong because SYNCEVOLUTION_LIBS must include -lrt (which can't be a dependency). Fixed by depending on libsyncevolution.la directly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f92e3e9..54b9e893 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1067,6 +1067,7 @@ fi
# When adding something here, remember to also update syncevolution.pc.in.
# -lrt is for clock_gettime() in the Timespec.h inline functions.
SYNCEVOLUTION_CFLAGS=-I`cd $srcdir && pwd`/src
+# Linker flags including libsyncevolution.la and some libs.
SYNCEVOLUTION_LIBS="src/syncevo/libsyncevolution.la -lrt"
AC_SUBST(SYNCEVOLUTION_CFLAGS)
AC_SUBST(SYNCEVOLUTION_LIBS)