summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-11-29 20:53:01 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2012-12-07 20:00:36 +0100
commit8bf486427fa8acfceef3b26d34fa303d6cfbc3e3 (patch)
tree03949e56f291c9e5607ec2d7dd91d05b2ce89b63 /configure.ac
parent970e4c5b5fb4aea4eacfdb133718295a6e94c6bc (diff)
PIM: search for phone number in EDS directly during startup
Bypass folks while it still loads contacts and search for a phone number directly in EDS. This is necessary to ensure prompt responses for the caller ID lookup. Done with a StreamingView which translates EContacts into FolksIndividuals with the help of folks-eds = edsf. Combining these intermediate results and switching to the final results is done by a new MergeView class. A quiescence signal is emitted after receiving the EDS results and after folks is done. The first signal will be skipped when folks finishes first. The second signal will always be send, even if switching to folks did not change anything. Together with an artificial delay before folks is considered done, that approach make testing more reliable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb66617e..340cf7ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -538,7 +538,7 @@ if test $enable_dbus_service = "yes"; then
if ! test -r "$srcdir/src/dbus/server/pim/locale-factory-$enable_dbus_pim.cpp"; then
AC_MSG_ERROR([invalid value '$enable_dbus_pim' for --enable-dbus-service-pim, $srcdir/src/dbus/server/pim/locale-factory-$enable_dbus_pim.cpp does not exist or is not readable])
fi
- PKG_CHECK_MODULES(FOLKS, [folks])
+ PKG_CHECK_MODULES(FOLKS, [folks folks-eds])
AC_DEFINE(ENABLE_DBUS_PIM, 1, [org._01.pim D-Bus API enabled])
DBUS_PIM_PLUGIN=$enable_dbus_pim
AC_SUBST(DBUS_PIM_PLUGIN)