summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2011-11-30 08:02:08 +0000
committerSyncEvolution Nightly Testing <syncevolution@syncevolution.org>2011-11-30 08:02:55 +0000
commit8fc4a378ba99e7e66aceae097242ac0384d97a75 (patch)
treea80a559cbd87c123704ae02f8ec772cb48db6c4c /configure.ac
parent7809e2488a9803ccce203566ff731c66b88da0d1 (diff)
GIO GDBus: fixed link error
Previously, DBUS_LIBS contained the dbus-1 libs required to link executables. When enabling GIO GDBus, GIO_DBUS_LIBS was set instead, but not used by most of the link rules (except for the new example). This caused link failures when using dynamic linking on recent Linux distros where all libraries used by an object file have to be listed explicitly - indirectly through some other shared object is not enough anymore. To solve this with minimal changes, DBUS_LIBS and DBUS_CFLAGS are reinterpreted as "the libs resp. flags needed for using D-Bus" and now get set for both dbus-1 and gio.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 163018d7..125d0286 100644
--- a/configure.ac
+++ b/configure.ac
@@ -449,7 +449,7 @@ AC_ARG_WITH([gio-gdbus],
[with_gio_gdbus="no"]))
AM_CONDITIONAL([COND_GIO_GDBUS], [test "x$with_gio_gdbus" = "xyes"])
AS_IF([test "x$with_gio_gdbus" = "xyes"], [need_glib=yes
- PKG_CHECK_MODULES([GIO_GDBUS], [gio-2.0 >= 2.26])
+ PKG_CHECK_MODULES([DBUS], [gio-2.0 >= 2.26])
AC_DEFINE([WITH_GIO_GDBUS],[],[Set if using GIO GDBus])])
PKG_CHECK_MODULES(KEYRING, [gnome-keyring-1], HAVE_KEYRING=yes, HAVE_KEYRING=no)