summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2011-11-22 20:09:07 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2011-11-28 10:18:19 +0100
commita88ba0a09176ace2791ccb08f3cd0a9de6a71b23 (patch)
tree968251c4fb786078fc0525fd36b6d1598db3fe2d /configure.ac
parent0f1bed33fe139483e832ec8134dc03998b2a08b7 (diff)
autotools: use pcre for regular expressions
Added the necessary autotools rules to use pcre in the src binaries and libsyncevolution. It's unconditionally required now, which makes it possible to add code depending on it without having to worry about the case without pcre. The alternative to pcre with its C++ binding would have been boost::Xpressive. pcre was chosen because it has UTF-8 support and is more common. boost::regex introduces an undesirable library dependency. The C POSIX regex code has no C++ binding and does not support easy replacement. README was updated accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d3a521ce..9ceec637 100644
--- a/configure.ac
+++ b/configure.ac
@@ -666,6 +666,10 @@ AC_SUBST(GUI_DESKTOP_FILES)
# as Debian Etch backport.
AX_BOOST_BASE(1.34)
+# C++ regular expression support is required often enough to make it
+# mandatory.
+PKG_CHECK_MODULES(PCRECPP, libpcrecpp)
+
# need rst2man for man pages
AC_ARG_WITH(rst2man,
AS_HELP_STRING([--with-rst2man=<path to reStructuredText to man converter>],