summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOve Kåven <ovek@arcticnet.no>2012-08-05 04:07:37 +0200
committerOve Kåven <ovek@arcticnet.no>2012-08-07 01:32:09 +0200
commitea16d760117c3d9f60a9c34968e0df94b6ea1acd (patch)
tree20ca0ca2c9b977bf1ddef7c7250c13d2244f3427 /configure.ac
parent8aff8fab34cd5aabf0b877933a5779cc2afffaa7 (diff)
Various packaging and build system patches for the Maemo 5 port.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index bf6b19ae..704da463 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,7 @@ if test "$enable_release_mode" = "yes"; then
AC_DEFINE(SYNCEVOLUTION_STABLE_RELEASE, 1, [binary is meant for end-users])
fi
-AM_INIT_AUTOMAKE([1.11.1 silent-rules subdir-objects -Wno-portability])
+AM_INIT_AUTOMAKE([subdir-objects -Wno-portability])
AM_PROG_CC_C_O
@@ -55,7 +55,8 @@ dnl Specify git revisions/branches without prefix, i.e., without 'origin'.
dnl We'll sort that out below.
define([SYNTHESISSRC_REVISION], [syncevolution-0.9])
AC_CONFIG_HEADERS(config.h)
-LT_INIT([dlopen])
+AC_LIBTOOL_DLOPEN
+AC_PROG_LIBTOOL
dnl check for programs.
AC_PROG_CXX
@@ -615,7 +616,11 @@ AX_BOOST_BASE(1.34)
# C++ regular expression support is required often enough to make it
# mandatory.
-PKG_CHECK_MODULES(PCRECPP, libpcrecpp)
+PKG_CHECK_MODULES(PCRECPP, libpcrecpp,,
+AC_CHECK_LIB(pcrecpp,main,
+AC_SUBST(PCRECPP_LIBS,-lpcrecpp),
+AC_MSG_ERROR([pcrecpp not found])
+))
# need rst2man for man pages
AC_ARG_WITH(rst2man,