summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@gmx.de>2008-01-19 20:11:31 +0000
committerPatrick Ohly <patrick.ohly@gmx.de>2008-01-19 20:11:31 +0000
commitda7022963b1fc48403acb41e23b9d9896fa6b2ac (patch)
treea86b3a75164152736577f7002c1862d7e80d05a1 /debian
parent1ccbd695eef6664c812f43c592032ccae74e722a (diff)
- patch libtool so that -Wl is inserted at the beginning of the command line
used to build modules - added -Wl,--as-needed to LDFLAGS during compilation git-svn-id: https://zeitsenke.de/svn/SyncEvolution/trunk@487 15ad00c4-1369-45f4-8270-35d70d36bdcd
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules7
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a15b87ba..44708a4b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+syncevolution (1:0.7-2) unstable; urgency=low
+
+ * compiled with --as-needed to avoid useless dependencies on libs which
+ are not available on ITOS 2008
+
+ -- Patrick Ohly <patrick.ohly@gmx.de> Sat, 19 Jan 2008 21:09:05 +0100
+
syncevolution (1:0.7-1) unstable; urgency=low
* updated upstream sources
diff --git a/debian/rules b/debian/rules
index 9f384312..52c33cc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,6 +27,9 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
CFLAGS = -Wall -g
+LDFLAGS = -Wl,--as-needed
+export CFLAGS
+export LDFLAGS
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CONFIGURE_FLAGS += CXXFLAGS="-g -O0"
@@ -46,6 +49,10 @@ config.status: configure
# which is more flexible but not the default because it requires a
# specific installation layout.
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(CONFIGURE_FLAGS) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+ # fix place of \$compiler_flags in -shared build line: our -Wl,--as-needed has
+ # no effect if it comes after the libs, which is where libtool 1.5.24 puts it
+ # normally
+ perl -pi -e 's/-shared (.*) \\\$$compiler_flags/-shared \\\$$compiler_flags $$1/' libtool
#Architecture
build: build-arch build-indep