aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-04-24 21:35:16 +0200
committerGuido Günther <agx@sigxcpu.org>2014-04-24 21:35:16 +0200
commitc1c26dcf9544dd2a198115a520bd5808088d52be (patch)
tree4bc2f85aefdec161d691b489ff116ec47c88b4d5 /configure.ac
Initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..514c78e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,40 @@
+AC_INIT(uplanfahr, 0.0)
+AC_CONFIG_SRCDIR(src/main.c)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_CONFIG_HEADER(config.h)
+AC_CONFIG_MACRO_DIR([m4])
+dnl Make automake keep quiet about wildcards & other GNUmake-isms
+AM_INIT_AUTOMAKE([1.11.1 subdir-objects no-dist-gzip dist-xz -Wno-portability])
+AC_CANONICAL_HOST
+
+AM_SILENT_RULES([yes])
+
+GTK_REQUIRED=3.0
+LIBPLANFAHR_REQUIRED=0.0.0
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+GLIB_GSETTINGS
+
+GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`
+AC_SUBST(GLIB_COMPILE_RESOURCES)
+
+UPLANFAHR_COMPILE_WARNINGS
+
+AC_DEFINE([_GNU_SOURCE], [], [Enable GNU extensions])
+
+PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)
+PKG_CHECK_MODULES(LIBPLANFAHR, libplanfahr-0.0 >= $LIBPLANFAHR_REQUIRED)
+
+dnl --enable-debug=(yes|no)
+AC_ARG_ENABLE(debug,
+ AS_HELP_STRING([--enable-debug=no/yes],[enable debugging output]),[],[enable_debug=no])
+if test x"$enable_debug" = x"yes"; then
+ AC_DEFINE(ENABLE_DEBUG, 1, [whether debugging is enabled])
+fi
+
+AC_CONFIG_FILES(Makefile
+ src/Makefile
+)
+AC_OUTPUT