aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..2dbeadc
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,50 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ $(WARN_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(LIBPLANFAHR_CFLAGS)
+ $(NULL)
+
+LDFLAGS = \
+ $(GTK_LIBS) \
+ $(LIBPLANFAHR_LIBS) \
+ $(NULL)
+
+noinst_PROGRAMS = uplanfahr
+
+uplanfahr_SOURCES = \
+ main.c \
+ uplanfahr.c uplanfahr.h \
+ uplanfahrwin.c uplanfahrwin.h \
+ uplanfahrprefs.c uplanfahrprefs.h \
+ uplanfahrtripview.c uplanfahrtripview.h \
+ resources.c
+
+BUILT_SOURCES = \
+ resources.c \
+ gschemas.compiled
+
+resources.c: uplanfahr.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/uplanfahr.gresource.xml)
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/uplanfahr.gresource.xml \
+ --target=$@ --sourcedir=$(srcdir) --generate-source
+
+gsettings_SCHEMAS = \
+ org.sigxcpu.uplanfahr.gschema.xml
+
+@GSETTINGS_RULES@
+
+gschemas.compiled: org.sigxcpu.uplanfahr.gschema.xml
+ $(GLIB_COMPILE_SCHEMAS) .
+
+EXTRA_DIST = \
+ window.ui \
+ app-menu.ui \
+ prefs.ui \
+ gears-menu.ui \
+ tripview.ui \
+ uplanfahr.gresource.xml \
+ org.sigxcpu.uplanfahr.gschema.xml
+
+CLEANFILES = \
+ gschemas.compiled
+