aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-04-18 14:46:37 +0200
committerGuido Günther <agx@sigxcpu.org>2014-04-18 15:14:58 +0200
commit38be6c5ccc11d70ee375e82e79e24e4dc320b8ae (patch)
tree6e768d7292d6c3b25f61fa733b1591a4de46d976 /debian/rules
parentb3e2fef966b266bfcfc554f732f78bf128cd62aa (diff)
Run tests during build
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bdf4a77..5ce9e1c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,12 +10,16 @@
#export DH_VERBOSE=1
%:
- dh $@
+ dh $@ --with python2
override_dh_installman:
pod2man man/whatmaps.pod man/whatmaps.8
dh_installman man/whatmaps.8
+override_dh_auto_test:
+ python setup.py nosetests
+ dh_auto_test
+
override_dh_autoclean:
rm -f man/whatmaps.8
dh_autoclean