aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Lobato García <me@daniellobato.me>2016-08-18 14:14:32 +0200
committerGitHub <noreply@github.com>2016-08-18 14:14:32 +0200
commit4dc8465be0b8f3f13b3a874b259b9c8ea71f02dd (patch)
tree2ba716d917fb7a75940eac028b7d2687d5ad5910 /setup.py
parentf399e489e2db052c235152ab9233dbdfa192985c (diff)
parent03f652e6678bf7933c1e6f5078648e216089f182 (diff)
Merge pull request #26 from theforeman/tests
Add some tests and conform to pep8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 12 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 1dbfc7e..4877532 100644
--- a/setup.py
+++ b/setup.py
@@ -18,21 +18,20 @@
#
# END OF COPYRIGHT #
-import subprocess
-from setuptools import setup, find_packages
-import os
+from setuptools import setup
-setup(name = "foreman_ansible_inventory",
- version = "0.0.3",
- author = u'Guido Günther',
- author_email = 'agx@sigxcpu.org',
- description = 'Ansible dynamic inventory that queries the Foreman',
- license = 'GPLv3+',
- classifiers = [
+setup(name="foreman_ansible_inventory",
+ version="0.0.3",
+ author=u'Guido Günther',
+ author_email='agx@sigxcpu.org',
+ description='Ansible dynamic inventory that queries the Foreman',
+ license='GPLv3+',
+ classifiers=[
'Environment :: Console',
'Programming Language :: Python :: 2',
'Operating System :: POSIX :: Linux',
],
- scripts = ['foreman_ansible_inventory.py'],
- requires = ["requests"],
-)
+ scripts=['foreman_ansible_inventory.py'],
+ requires=["requests"],
+ tests_require=['responses'],
+ )