aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2021-04-28 10:26:22 +0200
committerGuido Günther <agx@sigxcpu.org>2021-04-28 10:56:41 +0200
commitc341c19223e79359e14d59fc94cd41beb74e7003 (patch)
tree3e4acd4d480ab96b58285aaf262181328fd27caa /setup.py
parent35d91d5f1dbdeadb49aca1d91184b45aeb43a1b8 (diff)
setup.py: Allow for more liberal version numbers
Otherwise this causes trouble for backports, downstreams, etc.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 962bf14c..0cc31b9e 100755
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,9 @@ def _parse_changelog():
with open("debian/changelog") as f:
line = f.readline()
- m = re.match(".* \\(([0-9.]+)\\) ", line)
+ # Parse version from changelog without external tooling so it can work
+ # on non Debian systems.
+ m = re.match(".* \\(([0-9a-zA-Z.~\\-:+]+)\\) ", line)
if m:
return m.group(1)