aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 962bf14c..0cc31b9e 100755
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,9 @@ def _parse_changelog():
with open("debian/changelog") as f:
line = f.readline()
- m = re.match(".* \\(([0-9.]+)\\) ", line)
+ # Parse version from changelog without external tooling so it can work
+ # on non Debian systems.
+ m = re.match(".* \\(([0-9a-zA-Z.~\\-:+]+)\\) ", line)
if m:
return m.group(1)