summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2016-04-22 12:29:33 +0200
committerLubomir Rintel <lkundrak@v3.sk>2016-04-22 13:04:16 +0200
commit906f673ab4461cc42a49d7a3b290d2cfa2f403e9 (patch)
tree95aa1abfc8b4e46e8c1ef7dd033964e04db92dcc /Makefile.am
parenta9a17c632a0ea7aa7146b928fbef7eec2f815032 (diff)
build: don't include the full path to a plugin by default
Makes packagers a bit less sad. We always keep the full paths in /etc for compatibility.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 24174e0..ad796f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,13 +17,23 @@ nmvpnservicedir = $(NM_VPN_SERVICE_DIR)
nmvpnservice_DATA = nm-iodine-service.name
if WITH_LIBNM_GLIB
-nmvpnoldservicedir = $(sysconfdir)/NetworkManager/VPN
-nmvpnoldservice_DATA = nm-iodine-service.name
+# Install a file with full path to plugins for an old gnome-shell
+# https://bugzilla.gnome.org/show_bug.cgi?id=693590
+install-data-hook:
+ mkdir -p $(DESTDIR)$(sysconfdir)/NetworkManager/VPN
+ sed -e "1s|^|# This file is obsoleted by a file in $(NM_VPN_SERVICE_DIR)\n\n|" \
+ -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' \
+ -e 's|[@]PLUGINDIR[@]|$(libdir)/NetworkManager|g' \
+ <$(srcdir)/nm-iodine-service.name.in \
+ >$(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-iodine-service.name
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(sysconfdir)/NetworkManager/VPN/nm-iodine-service.name
endif
nm-iodine-service.name: $(srcdir)/nm-iodine-service.name.in
sed -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|g' \
- -e 's|[@]PLUGINDIR[@]|$(libdir)/NetworkManager|g' \
+ -e 's|[@]PLUGINDIR[@]/|@NM_PLUGIN_DIR@|g' \
$< >$@
DISTCHECK_CONFIGURE_FLAGS = --enable-more-warnings=yes