summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2012-02-28 14:34:47 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2012-02-28 20:41:38 +0000
commitd604d99d39affafcd341344b30e86741667a75d4 (patch)
tree9f13f6aaadeb7bbf496956326cc99cee76aea97e /configure.ac
parent02c08c471de2c93ce87166f7f139d7e92510653d (diff)
autotools: replaced obsolete QMAKE -query
Using pkg-config to find QtDBus and QtCore cflags and libs is more reliable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index baefd615..4e3354cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,10 +498,10 @@ then
then
KDEKWALLETFOUND=yes
if ! test "$KDE_KWALLET_CFLAGS"; then
- KDE_KWALLET_CFLAGS="-I`$KDE4_CONFIG --path include` -I`$KDE4_CONFIG --path include`/KDE -I`$QMAKE -query QT_INSTALL_HEADERS` `pkg-config --cflags QtDBus`"
+ KDE_KWALLET_CFLAGS="-I`$KDE4_CONFIG --path include` -I`$KDE4_CONFIG --path include`/KDE `pkg-config --cflags QtDBus QtCore`"
fi
if ! test "$KDE_KWALLET_LIBS"; then
- KDE_KWALLET_LIBS="-lkdeui -lkdecore -L`kde4-config --install lib` `pkg-config --libs QtDBus`"
+ KDE_KWALLET_LIBS="-lkdeui -lkdecore -L`kde4-config --install lib` `pkg-config --libs QtDBus QtCore`"
fi
AC_LANG_PUSH(C++)
old_CPPFLAGS="$CPPFLAGS"