summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kühl <chrisk@openismus.com>2011-10-01 07:24:57 +0200
committerPatrick Ohly <patrick.ohly@intel.com>2011-11-29 16:38:38 +0000
commitdd3cc6afa970b32962c8bf054d64a975d894bbb3 (patch)
treea8fdc7867bf465245a3325e96aa34f4044b4194c /configure.ac
parent103dfe4f7385badb10a332c121f602341fea3eec (diff)
dbus: Create dbus wrapper using the GIO GDBus dbus implementation
Background: Prior to this patch a C++ wrapper around Bluez gdbus, a convienience wrapper around the low-level libdbus, was used by syncevo-dbus-server. This patch introduces a second C++ wrapper around the GIO GDBus implementation. The reason for introducing this second wrapper is to move away from using the in-tree copy of Bluez gdbus and towards a more well-maintained dbus implementation. Also, libdbus was not designed to be thread-safe whereas GIO GDBus was. The GIO GDBus wrapper retains the same public api as the first one. This means the consumers of this wrapper (syncevo-dbus-server, for example) have remained almost completely untouched. The only exceptions are in the few case where libdbus objects where used directly by the consuming class. The choice of which wrapper is determined at configure time. The option can be explicitly set using the --with-gio-gdbus and --without-gio-gdbus flags or, if no flag is given, an adequate version of GIO is search for. If found, the GIO GDBus wrapper is chosen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 17324196..240be1fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -449,7 +449,8 @@ AC_ARG_WITH(gio-gdbus,
[with_gio_gdbus="no"]))
AM_CONDITIONAL([COND_GIO_GDBUS], [test "x$with_gio_gdbus" = "xyes"])
AS_IF([test "x$with_gio_gdbus" = "xyes"], [need_glib=yes
- PKG_CHECK_MODULES([GIO_GDBUS], [gio-2.0 >= 2.26])] )
+ PKG_CHECK_MODULES([GIO_GDBUS], [gio-2.0 >= 2.26])
+ AC_DEFINE([WITH_GIO_GDBUS],[],[Set if using GIO GDBus])])
PKG_CHECK_MODULES(KEYRING, [gnome-keyring-1], HAVE_KEYRING=yes, HAVE_KEYRING=no)
AC_ARG_ENABLE(gnome-keyring,