aboutsummaryrefslogtreecommitdiff
path: root/at76_usb.h
Commit message (Collapse)AuthorAge
* [PATCH] Bump version to 0.16HEADversion_0.16masterPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Replace at76_assert with standard WARN_ON and BUG_ON macrosPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Improve formatting of the headers, use tabs where possiblePavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Improve comments, reorder some fields in at76_usb.hPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove priv->open_count, it's write-onlyPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Eliminate priv->rx_urb, it shouldn't be therePavel Roskin2007-07-15
| | | | | | | | | | Pass the urb as data to the tasklet instead of priv. Remove some paranoid sanity checks in at76_rx_tasklet(). Rename at76_submit_rx_urb() to at76_submit_read_urb() to avoid confusion. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove unused priv->ctrl_urb and priv->ctrl_bufferPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Expand request type macros in usb_control_msg() callsPavel Roskin2007-07-15
| | | | | | | They were used inconsistently. Besides, they don't make the code more readable. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Convert management timer/work to a delayed workPavel Roskin2007-06-26
| | | | | | | | | | | | This is likely not the final approch, as the code handles several different timeouts and may need to be split. Anyway, it would be easier to split a single delayed work than a timer and a work. When handling beacons, cancel the work first, as we want the timeout handler to be deferred. The delayed workqueue API doesn't seem to provide a nicer way to do it. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Implement 5 second timeout in at76_wait_completion()Pavel Roskin2007-06-26
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Replace a work/timer combination for restarts with a delayed workPavel Roskin2007-06-26
| | | | | | | | | | Decrease the delay to half second. It's enough to cover all requests from one iwconfig command, and improves the response time. Cancel the delayed work in at76_stop(). We don't need any restarts if the interface is down. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Simplify at76_set_card_command()Pavel Roskin2007-06-16
| | | | | | | | Add "data" field to struct at76_command to avoid dubious code to access data beyound the end of structure. Don't make handle 0-byte buffer as a special case. Avoid extra indentation. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Eliminate macros containing offsetof for MIB structuresPavel Roskin2007-06-16
| | | | | | | | | They make it harder to check correctness of MIB requests. For instance, STATION_ID_OFFSET doesn't show that it's an offset in struct mib_mac_mgmt, so it's not obvious if priv->mib_buf.type is set to MIB_MAC_MGMT correctly. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Add full support for "auto" preamblePavel Roskin2007-06-16
| | | | | | | | Don't assume that there are just two settings, "long" and "short". Provide textual description in the output of "iwpriv get_preamble" in the same format as in ipw2100 and ipw2200. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Implement "get" counterparts for iwpriv callsPavel Roskin2007-06-16
| | | | | | | | | | Rename all iwpriv calls to start with "get" or "set" for consistency. Eliminate gap in the ioctl numbers. Rename "intl_roaming" to "intl_scan", because it's really affects scanning only. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Improve info messages, avoid printing full pathPavel Roskin2007-06-14
| | | | | | | | | | | | | Never use __FILE__, as it prints full path to the driver, which is rarely needed. Use DRIVER_NAME instead. Replace all occurrences of info() with printk() calls. Ensure that the messages are properly formatted and use the netdevice name if possible. Print MAC address, firmware version and regulatory domain after the device is registered, so we can provide the device name. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Save results of usb_sndbulkpipe() and usb_rcvbulkpipe()Pavel Roskin2007-06-14
| | | | | | | Calculate the pipe numbers on startup and keep them in at76_priv instead of keeping the endpoint numbers. Pipe numbers don't change. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Simplify dumping hex dataPavel Roskin2007-06-14
| | | | | | | | | | | | | | | Use rotating buffer pool in mac2str() and hex2str(). This makes it unnecessary to allocate any buffers for either function, and also allows to use mac2str() more than once in the same expression. Move mac2str() and hex2str() closer together. Replace hex2str() with mac2str() where appropriate. For other hex2str() calls, always use "-" separator to improve readability. Check buffer length in hex2str(). Reformat some expressions along the way. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't use workqueue to reschedule IBSS creationPavel Roskin2007-06-14
| | | | | | | Scheduling is done in process context, so it can be avoided. Merge at76_work_start_ibss() into at76_start_ibss(). Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't keep priv->interface, use USB interface provided in at76_probe()Pavel Roskin2007-06-09
| | | | | | This reduces driver's dependency on USB internals. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Decouple networking from firmware downloadPavel Roskin2007-06-09
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Move all firmware related data from struct at76_priv to struct fwentry. Move struct fwentry to the header file. Share the firmware data between devices. Never load firmware version or anything else into firmwares[], as one broken device can mess it for others. Use temporary structures instead. Change at76_load_internal_fw() and at76_load_external_fw() not to require struct at76_priv, which is allocated as part of the network device. at76_disconnect() should check if priv is allocated. Don't use priv->istate to track the firmware loading, as it's done in a predictable consecutive manner now. No state machine is needed at this point. There should be no priv at all before the firmware is loaded. Until the device is fully initialized, priv->istate should be INIT. Don't use mutexes during firmware download for the same reason. In fact, they were used incorrectly since priv is not the same during internal and external firmware download. Parse firmware immediately after loading in a new function at76_load_firmware() replacing at76_parse_fw() and parts of at76_probe(). Don't access udev before usb_get_dev() is called and be careful to call usb_put_dev() for all errors. Improve error handling and diagnostics in the affected code. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Run at76_usb.h through LindentPavel Roskin2007-06-05
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove support for channel scanning in monitor modePavel Roskin2007-06-05
| | | | | | | | This should be implemented by the userspace. No other Linux driver does that. The expected behavior is that the driver stays on the same channel while in monitor mode. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't document endianess in comments, it's documented by the typePavel Roskin2007-06-05
| | | | | | While at that, improve the affected comments. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename request structures to make them distinct from functionsPavel Roskin2007-06-05
| | | | | | | at76_start_scan was both a function and a structure. Use "req" in the structure names to indicate that they are requests. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Internal firmware download should just sleep without any timersPavel Roskin2007-06-03
| | | | | | | Timers are justified if they are scheduled in the interrupt context or if they are modified. Neither is the case. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't reschedule firmware loadingPavel Roskin2007-06-03
| | | | | | | | | at76_probe() is run in the process context and doesn't need to delay the firmware download. Rescheduling doesn't guarantee the execution order, so it's better to make the order predictable. It also makes it possible to handle errors in the firmware download. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename tasklet to rx_tasklet, the former is too genericPavel Roskin2007-06-03
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Replace semaphores with mutexesPavel Roskin2007-05-02
| | | | | | Semaphores are overkill for simple locking. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Call private data (at76_priv) "priv", not "dev", the later is ambiguousPavel Roskin2007-05-02
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename at76_get_fw_info() to at76_parse_fw(), fully rewritePavel Roskin2007-05-02
| | | | | | | | | | | | Use a structure to describe the firmware header. Don't pass any arguments fpr output, just pass the pointer to the private data. Move some debugging output there to avoid code duplication. Parse firmware even if it doesn't need to be loaded. Keep firmware version information in the private data. It's still re-read from the card, but now we have a valid version earlier. Signed-off-by: Pavel Roskin <proski@gnu.org>
* move hw_rates, channel_frequency, snapsig and rfc1042 sig out of the header fileGuido Guenther2007-05-01
| | | | Mark all of them as const and remove the size from hw_rates.
* [PATCH] Rename "site survey" to "scan", because it's a scan and nothing elsePavel Roskin2007-04-27
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Assorted minor comment changesPavel Roskin2007-04-27
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Split workqueues into separate handlersPavel Roskin2007-04-27
| | | | | | | | | at76_defer_event() is too large and unmanageable. Use separate work queues for every task. This is a formal split with minimal formating and comment changes. Many layers of indirection can and should be eliminated later. Timers should be combined into delayed works. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Standardize on radiotap headers for monitor modePavel Roskin2007-04-17
| | | | | | | | Remove support for bare 802.11 and prism headers. Remove private ioctl "monitor", it's obsolete. Only provide data available for the specific packet. Don't pass any average stats. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove nickname supportPavel Roskin2007-04-13
| | | | | | | It's not supported in the hardware, so it shouldn't be in the software. It's not a feature required for Linux inclusion. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Use safer declaration for at76_priv_handlersPavel Roskin2007-04-13
| | | | | | | Don't rely on the order of fields. Specify indices explicitly. Use shorter names for the handlers and for corresponding ioctl numbers. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove unused and write-only fields from some structuresPavel Roskin2007-04-13
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Change buffer pointers to void* or safer types to avoid castsPavel Roskin2007-04-13
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Move union of struct hwcfg_* to at76_usb.h, give it a namePavel Roskin2007-04-13
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* rename dbg() to at76_dbg and assert() to at76_assert()Guido Guenther2007-04-02
| | | | this allows us to get rid of dbg_uc() and #undef dbg
* put functions and structures into the at76_ namespace, rename remaining ↵Guido Guenther2007-04-02
| | | | AT76C503 macros
* cleanup PM code a bit:Guido Guenther2007-03-11
| | | | | | | | | | * rename PM_* constants * drop superflous parameter from set_pm_mode * get rid of dev->pm_beacon_period * reset pm_mode to off in ad-hoc and monitor mode (actually allow to turn of PM at all) * set pm capabilities in iw_handler_get_range() * iw_handler_set_range(): reject timeouts values, they're unsupported * drop pm_period and pm_mode module parameters
* dump_bss_table: get rid of useless force_output parameter and obuf_s in theGuido Guenther2007-03-11
| | | | at76c503a structure
* rename KEVENT_* to AT76_DEVENT, also rename the corresponding functions andGuido Guenther2007-03-10
| | | | variables
* cleanup some comments and remove duplicate debug codeGuido Guenther2007-03-10
|
* use C99 array initializers for firmware namesGuido Guenther2007-03-10
|
* run through Lindent and merge in most of the hunksGuido Guenther2007-03-09
|
* [PATCH] Reuse more structures from Linux ieee80211 headersPavel Roskin2007-03-06
| | | | | | | | | | | Eliminate all local definitions for management frames. Use Linux structures instead. Use struct ieee80211_info_element for information elements in management frames. Use min_t() instead of min() in the affected code when casts are already present or would be needed. Signed-off-by: Pavel Roskin <proski@gnu.org>